Flow (FLOW) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 27, 2024 - 08:28 UTC
Investigating
We're investigating an issue with the Flow (FLOW) funding gateway. Deposits and withdrawals will be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Jun 26, 2024 - 08:15 UTC
This incident affected: Digital Currency Funding (Flow (FLOW)).