Etana Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 08:06 UTC
Investigating
We are receiving reports that the https://etana.com website is down. We are urgently reaching out to the Etana team for an update on this and we will update you when we get further details.
Posted Oct 30, 2019 - 04:54 UTC
This incident affected: Fiat Currency Funding (Etana Custody).