Kraken to Kraken Futures Transfer Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 02, 2020 - 18:04 UTC
Investigating
We're investigating an issue with the Kraken Futures Transfers. Transfers to Kraken Futures are currently delayed. We will provide any updates as soon as possible.
Posted May 02, 2020 - 15:33 UTC
This incident affected: Kraken Futures (Cross-Exchange Transfers).