Mina (MINA) Funding Unavailable
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 15:44 UTC
Investigating
We're investigating an issue with the Mina (MINA) funding gateway. Deposits and withdrawals are currently unavailable - transfers made during this time will be processed delayed. We will provide any updates as soon as possible.
Posted Oct 05, 2021 - 15:19 UTC
This incident affected: Digital Currency Funding (Mina (MINA)).