Fidor Deposits Temporarily Suspended
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 28, 2019 - 22:04 UTC
Update
Issues with Fidor deposits have now been resolved.
Posted 4 months ago. Mar 28, 2019 - 20:51 UTC
Investigating
Fidor deposits have been temporarily suspended. This does not affect withdrawals. We are working on resolving the issue and will update as soon as we have further information.
Posted 4 months ago. Mar 28, 2019 - 18:55 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits).