Some SEPA Withdrawals through Fidor are experiencing an issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 13, 2021 - 11:59 UTC
Investigating
About 20% of withdrawals are being failed automatically. Clients who got their withdrawals failed need to try again until they get processed.
We have already contacted Fidor IT support and they are currently investigating the issue.
Posted May 12, 2021 - 08:45 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA).