Tezos (XTZ) deposit and withdrawal delayed
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 21:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2021 - 17:54 UTC
Investigating
We are investigating some connections issues with Tezos (XTZ) network. Deposits and withdrawals can be delayed. We will update as soon as possible.
Posted Jul 02, 2021 - 11:49 UTC
This incident affected: Digital Currency Funding (Tezos (XTZ)).