Monero (XMR) Deposit and Withdrawal Delays
Incident Report for Kraken
Resolved
The Monero (XMR) delay has been resolved and deposit and withdrawal times are returning to normal.
Posted 6 months ago. Apr 11, 2018 - 14:47 UTC
Investigating
We are currently experiencing delays with deposits and withdrawals for Monero (XMR). We are working to resolve the issue and will update as soon as we have more information.
Posted 6 months ago. Apr 11, 2018 - 13:20 UTC