Secret Network (SCRT) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 10, 2022 - 10:51 UTC
Investigating
We're investigating an issue with the Secret Network (SCRT) funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted May 10, 2022 - 09:31 UTC
This incident affected: Digital Currency Funding (Secret Network (SCRT)).