Stellar Lumens (XLM) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 06:34 UTC
Investigating
We are currently experiencing delays processing deposits and withdrawals for Stellar Lumens (XLM). Our engineers are aware of the issue and are currently investigating it.

Trading is not impacted.

We will provide an update as soon as possible.
Posted Jun 19, 2020 - 05:55 UTC
This incident affected: Digital Currency Funding (Stellar Lumens (XLM)).