Kraken Futures Transfer Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 18:34 UTC
Investigating
Some clients have reported issues with Kraken Futures transfers. We are investigating and will provide an update as soon as we have more information.
Posted Oct 11, 2019 - 18:21 UTC
This incident affected: Kraken Futures (Cross-Exchange Transfers).