Kraken Futures - Performance is degraded
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 19, 2022 - 10:21 UTC
Monitoring
We have identified the issue and our team is currently working on a fix.
Posted Jun 19, 2022 - 09:56 UTC
Investigating
We are currently investigating performance issues on the futures platform. We will reach out with any updates.
Posted Jun 19, 2022 - 09:38 UTC
This incident affected: Kraken Futures (User Interface, REST API, WebSockets API).