Issue With Debit / Credit Card Payments
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jan 18, 2021 - 03:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2021 - 23:56 UTC
Investigating
Some clients have reported issues and/or failed payments when using debit / credit cards. We are currently investigating the issue and will provide any updates as soon as possible.
Posted Jan 17, 2021 - 23:23 UTC
This incident affected: Payment Methods (Debit / Credit Cards).