Client Balances are not showing as updated.
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 19:26 UTC
Investigating
Due to the previously communicated issues with the Trading Engine, some clients might find that their balances are not updated after deposits are credited. This issue has been mitigated and clients' balances will be updated asap.
Posted Jul 22, 2022 - 14:05 UTC
This incident affected: Website.