EOS Transaction Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 11, 2018 - 20:54 UTC
Investigating
We are currently experiencing delays with EOS deposits and withdrawals. We are working to resolve the issue and will update as soon as we have further information.
Posted 2 months ago. Sep 11, 2018 - 09:11 UTC
This incident affected: Digital Currency Funding (EOS (EOS)).