Domestic Pound Sterling (GBP) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved and funding operations have been fully restored. Deposits and withdrawals are being processed normally. Thank you for your patience.
Posted Jun 28, 2020 - 15:43 UTC
Investigating
We are currently experiencing intermittent delays with domestic Pound Sterling (GBP) funding through Clear Junction. We are investigating the issue and will provide any update as soon as we have further information.
Posted Jun 28, 2020 - 15:31 UTC
This incident affected: Fiat Currency Funding (Pound Sterling (GBP) - Domestic).