Flow (FLOW) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 14:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2022 - 12:57 UTC
Identified
We are currently investigating an issue with Flow (FLOW) network. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Jul 26, 2022 - 17:22 UTC
This incident affected: Digital Currency Funding (Flow (FLOW)).