Algorand (ALGO) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 29, 2022 - 15:48 UTC
Identified
We're investigating an issue with the Algorand (ALGO) funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Dec 29, 2022 - 14:37 UTC
This incident affected: Digital Currency Funding (Algorand (ALGO)).