Cardano (ADA) Funding Delays
Incident Report for Kraken
Resolved
Cardano deposit delays have been resolved, and deposit times have returned to normal.
Posted 6 days ago. Dec 04, 2018 - 21:55 UTC
Investigating
We are currently experiencing issues with Cardano (ADA) deposits and withdrawals. We are working to resolve the issue and will update as soon as we have further information.
Posted 6 days ago. Dec 04, 2018 - 20:32 UTC
This incident affected: Digital Currency Funding (Cardano (ADA)).