FIL Deposit and Withdrawal Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 22:06 UTC
Identified
We are currently resolving an issue that is causing FIL deposits and withdrawals to be delayed.
Posted Nov 13, 2020 - 17:41 UTC
This incident affected: Digital Currency Funding (Filecoin (FIL)).