Intermittent Trading Issues for Bifrost (BNC)
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 13, 2022 - 07:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 07:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 11, 2022 - 07:34 UTC
Investigating
Clients may experience trading issues for BNC on the Mobile and Web user interface when trying to buy and sell BNC. Clients may see an error advising them to reach out to customer support. We are currently investigating this issue.
Posted May 10, 2022 - 17:31 UTC
This incident affected: Digital Currency Funding (Bifrost (BNC)).