System Email - Delivery Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 19:28 UTC
Identified
The cause is identified and the fix is being worked on at the moment. We will deliver feedback as soon as news is available.
Posted Jun 09, 2022 - 12:43 UTC
This incident affected: Website.