Delayed US Dollar (USD) Withdrawals Via Deltec
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 13, 2021 - 00:23 UTC
Investigating
We're investigating an issue with the Deltec funding gateway. US Dollars (USD) withdrawals via deltec are currently delayed. Other funding methods are not affected. We will provide any updates as soon as possible.
Posted Nov 12, 2021 - 23:17 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).