XRP Withdrawal Delay
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 14, 2019 - 18:00 UTC
Investigating
We are experiencing delayed XRP withdrawals for some clients. We are working to resolve these delays and will update once we have more information.
Posted 2 months ago. Aug 14, 2019 - 17:49 UTC
This incident affected: Digital Currency Funding (Ripple (XRP)).