Connection issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 09, 2017 - 17:17 UTC
Investigating
Clients are seeing slow response from the website and API and even connection timeouts in some cases. We also have reports of delays in withdrawals. We are investigating these issues and working to resolve as quickly as possible.
Posted Jul 09, 2017 - 16:00 UTC