Cardano (ADA) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 11, 2020 - 06:47 UTC
Investigating
We are currently experiencing delays processing deposits and withdrawals for Cardano (ADA)
. Our engineers are aware of the issue and are currently investigating it.

Trading is not impacted.

We will provide an update as soon as possible.
Posted Jul 11, 2020 - 05:22 UTC
This incident affected: Digital Currency Funding (Cardano (ADA)).