Signature Withdrawals Unavailable
Incident Report for Kraken
Resolved
Signature withdrawal functionality has been fully restored, and you should now be able to withdraw USD via Signature without issue.
Posted about 1 month ago. Mar 18, 2019 - 21:57 UTC
Investigating
We are currently experiencing delays with Signature Domestic and International (USD) withdrawals. We are investigating the issue and will update as soon as we have further information.
Posted about 1 month ago. Mar 18, 2019 - 16:39 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic, US Dollar (USD) - International).