Website Connectivity Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 02, 2018 - 19:55 UTC
Investigating
We have received reports that clients are experiencing difficulties connecting to trade.kraken.com and cryptowat.ch. We are investigating the issue and will post an update as soon as we have more information.
Posted 2 months ago. Aug 02, 2018 - 19:51 UTC
This incident affected: Website.