BlueOrange Bank (EUR) withdrawal
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 13, 2019 - 12:23 UTC
Investigating
We are currently experiencing issues with BlueOrange Bank withdrawals (EUR). We are working to resolve the issue and will update as soon as we have further information.
Posted 5 months ago. Mar 13, 2019 - 09:07 UTC