Domestic USD Deposit Incident
Incident Report for Kraken
Resolved
This incident has now been resolved. Our domestic USD wire procedure is operational for all our US clients.
Posted 26 days ago. Aug 31, 2018 - 03:05 UTC
Investigating
We are currently investigating an incident affecting users completing our domestic USD deposit procedure.
Posted 27 days ago. Aug 29, 2018 - 18:58 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Synapse Domestic).