Cardano (ADA) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 13:10 UTC
Identified
We've identified an issue with the Cardano (ADA) funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Jun 13, 2022 - 10:50 UTC
This incident affected: Digital Currency Funding (Cardano (ADA)).