Polkadot (DOT) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 23, 2021 - 16:44 UTC
Identified
The Polkadot (DOT) deposits and withdrawals are available but slightly delayed. This is due to the Polkadot network's block finalization delays. We will provide updates as as soon as there are any changes.
Posted Jun 20, 2021 - 19:27 UTC
This incident affected: Digital Currency Funding (Polkadot (DOT)).