Ethereum Transaction Delays
Incident Report for Kraken
Resolved
Ethereum deposit/withdrawal times have returned to normal.
Posted 3 months ago. Jun 02, 2018 - 08:03 UTC
Investigating
We are currently experiencing delays with deposits and withdrawals for Ethereum. Our development team is investigating the issue.
Posted 3 months ago. Jun 02, 2018 - 03:18 UTC
This incident affected: Website.