USDC Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 20:25 UTC
Investigating
We're investigating an issue with the USDC funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Feb 19, 2021 - 19:37 UTC
This incident affected: Digital Currency Funding (USD Coin (USDC) - ERC20).