ZCash (ZEC) Funding Maintenance
Incident Report for Kraken
Resolved
The maintenance for our ZCash (ZEC) funding system has been completed. Deposits and withdrawals made during the maintenance will be processed shortly.
Posted 16 days ago. Sep 04, 2019 - 12:39 UTC
Investigating
We are currently undertaking some unscheduled maintenance for our ZCash (ZEC) funding system. This maintenance will take approximately 1 hour. Deposits and withdrawals made during the maintenance will be processed once the ZCash funding system is back online.
Posted 16 days ago. Sep 04, 2019 - 10:10 UTC
This incident affected: Digital Currency Funding (ZCash (ZEC)).