Etana Funding Issue
Incident Report for Kraken
Resolved
The delays for Etana funding have now been resolved. We will continue to monitor the situation closely.
Posted 2 months ago. May 13, 2019 - 15:20 UTC
Investigating
We are currently experiencing delays with Etana funding. We are investigating the issue and will provide an update as soon as we have any more information.
Posted 2 months ago. May 13, 2019 - 13:20 UTC