Support Request Submission Issues
Incident Report for Kraken
Resolved
We have identified and resolved the issue, and clients should no longer have any difficulty submitting a support request via the Support Center.
Posted 4 months ago. Jun 26, 2019 - 19:23 UTC
Investigating
We’ve received reports of clients experiencing difficulties in submitting support requests via the Support Center. Our Live Chat support option does not appear to be experiencing similar issues. We are investigating this issue and will provide updates as they become available.
Posted 4 months ago. Jun 26, 2019 - 17:44 UTC
This incident affected: Support.