System Email - Delivery Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 01:28 UTC
Update
We are continuing to investigate this issue.
Posted Jul 27, 2020 - 22:26 UTC
Investigating
We are investigating reports of delays for system emails (account activation, withdrawal confirmation). Please attempt to request the email again (after the expiration time has passed). We're investigating the issue and will provide any updates as soon as possible.
Posted Jul 27, 2020 - 22:18 UTC
This incident affected: Website.