Delayed automated email delivery
Incident Report for Kraken
Resolved
Automated email delivery has returned to normal. Thanks for your patience.
Posted Jul 14, 2018 - 05:41 UTC
Investigating
We have reports that some automated emails may be delayed. We are investigating the issue and will post updates as we get them.
Posted Jul 14, 2018 - 00:38 UTC