Funding issues
Incident Report for Kraken
Resolved
Funding delays have been resolved. Deposit and withdrawal times should return to normal. Thank you for your patience.
Posted 8 months ago. Apr 04, 2018 - 23:47 UTC
Investigating
We are currently experiencing issues across all funding methods. Please expect crypto and fiat deposits to be delayed until we identify and resolve the issue.
Posted 8 months ago. Apr 04, 2018 - 14:21 UTC