Cardano (ADA) Instant Buy/Sell/Convert Temporarily Unavailable
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 27, 2021 - 12:18 UTC
Investigating
We're investigating an issue. Cardano (ADA) instant buy/sell/convert is temporarily unavailable. We will provide any updates as soon as possible.
Posted Dec 27, 2021 - 10:19 UTC
This incident affected: Digital Currency Funding (Cardano (ADA)).