Ethereum (ETH) Funding Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 18, 2019 - 08:49 UTC
Investigating
Ethereum (ETH) deposits and withdrawals are currently delayed. We are investigating the issue, and will provide any updates as soon as possible.
Posted about 1 month ago. Sep 18, 2019 - 06:49 UTC
This incident affected: Digital Currency Funding (Ether (ETH)).