Bitcoin Cash (BCH) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 28 days ago. Nov 13, 2018 - 09:05 UTC
Update
Bitcoin Cash (BCH) Funding has been restored. All pending deposits and withdrawals should now have been processed.
Posted 28 days ago. Nov 13, 2018 - 07:13 UTC
Investigating
We are currently experiencing delays with our Bitcoin Cash(BCH) funding systems. We are working to resolve the issue and we will update as soon as we have further information.
Posted 28 days ago. Nov 13, 2018 - 06:01 UTC
This incident affected: Digital Currency Funding (Bitcoin Cash (BCH)).