Flow (FLOW) Deposit Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Apr 08, 2021 - 07:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 07, 2021 - 01:22 UTC
Investigating
We're investigating an issue with the Flow (FLOW) funding gateway. We will provide any updates as soon as possible.
Posted Apr 06, 2021 - 21:22 UTC
This incident affected: Staking (Flow (FLOW) - On-chain) and Digital Currency Funding (Flow (FLOW)).