Pound Sterling (GBP) withdrawals issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 19:45 UTC
Identified
Our funding partner has identified the issue and their team is working to resolve it as soon as possible. We will provide updates as they become available.
Posted Dec 11, 2019 - 17:05 UTC
Investigating
We are receiving reports and have confirmed on our end that there is an issue with GBP withdrawals failing. We are working with our funding partner's team to investigate and resolve the issue as soon as possible. Updates will be provided as they become available.
Posted Dec 11, 2019 - 11:05 UTC
This incident affected: Fiat Currency Funding (Pound Sterling (GBP) - Domestic).