Site connectivity issues
Incident Report for Kraken
Resolved
The issue has now been resolved. We will continue to monitor performance closely and will provide an update if anything changes.
Posted 23 days ago. May 01, 2019 - 08:14 UTC
Investigating
We are receiving reports of clients having difficulty connecting to Kraken.com. We are monitoring the situation and working to resolve the issue. An update will be posted as soon as we have more information.
Posted 23 days ago. May 01, 2019 - 07:49 UTC
This incident affected: Website.