Intermittent Debit / Credit Card, Apple Pay, Google Pay Purchases Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 13, 2022 - 11:07 UTC
Identified
We are investigating intermittent issues with debit / credit card, Apple Pay, Google Pay Purchases. Some clients might be experiencing failed transactions temporarily. We are working to resolve the issue and will provide any updates as soon as possible.
Posted May 12, 2022 - 11:46 UTC
This incident affected: Payment Methods (Euro (EUR) - Debit / Credit Cards, US Dollar (USD) - Domestic).