Silvergate Exchange Network (SEN) Withdrawal Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jan 20, 2021 - 12:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2021 - 12:18 UTC
Investigating
We are investigating an issue with USD withdrawals (domestic & international) through Silvergate Exchange Network (SEN). Withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Jan 20, 2021 - 10:51 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic, US Dollar (USD) - International).