Intermittent Debit / Credit Card, Apple Pay, Google Pay Purchases Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 11, 2022 - 15:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2022 - 15:04 UTC
Update
Purchases with debit/credit card, Apple Pay, Google Pay and ACH Online Banking are temporarily unavailable. Our team are working hard to resolve the issue. We will update as soon as possible.
Posted May 11, 2022 - 14:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 11, 2022 - 13:38 UTC
Investigating
We are investigating intermittent issues with debit / credit card, Apple Pay, Google Pay Purchases. Some clients might be experiencing failed transactions temporarily. We are working to resolve the issue and will provide any updates as soon as possible.
Posted May 11, 2022 - 13:25 UTC
This incident affected: Payment Methods (Euro (EUR) - Debit / Credit Cards, US Dollar (USD) - Domestic).