Kusama (KSM) Network Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 28, 2021 - 16:38 UTC
Investigating
Kusama (KSM) withdrawals are currently unavailable while we are investigating an issue with the Kusama network. We will provide any updates as soon as possible.
Posted Jun 28, 2021 - 14:40 UTC
This incident affected: Digital Currency Funding (Kusama (KSM)).